RMAN-10002 ORA-00096

RMAN may fail with error RMAN-10002: ORACLE error: ORA-00096: invalid value SIGNATURE for parameter remote_dependencies_mode, must be from among NO_OVERFETCH, OVERFETCH. The error message is confusing here as remote_dependencies_mode can only take two values: TIMESTAMP or SIGNATURE. The suggested values may be anything else from another parameter. When running RMAN command, it tries to do … Read more

Using variables in RMAN

When using RMAN catalog it is preferred to use backup script stored in catalog. It is best if scripts can be reused for different retention. You can use variables in RMAN script this way: CREATE global script global_backup_full_database comment ‘backup full of database. Parameter sysdate+n,tag db, tag archivelog’ { allocate channel c1 TYPE SBT_TAPE PARMS … Read more

DRA: Data Recovery Advisor

The data recovery advisor makes it possible to detect corruption or loss of data, determines the actions to be carried out and suggests the actions to be taken to repair the database. This can saves you lots of hours if you are not sure what you can do. LIST FAILURE The LIST FAILURE command allows … Read more